Problems playing MKA files

QuadraphonicQuad

Help Support QuadraphonicQuad:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

humprof

Junior Senior
QQ Supporter
Joined
Jun 10, 2016
Messages
6,333
Location
NoCal
I have some Dolby Atmos files that were encoded as MKA.

I'm new to Kodi, but Kodi doesn't seem to want to play them. (Maybe there's a plug-in I need?)

If I right-click on one of the files to choose a different app to open it with, Windows File Explorer freezes up.

Does anyone know of an easy way to convert MKA to M4A? I know I can play M4A Atmos files with the Windows "Movies & Music" app built in to Windows 10.
 
What version of Kodi?

Kodi needs tagged music but doesn’t recognise MKA tags.

The workaround is to create a CUE file, then scan your music source (or that single MKA folder) to add to its library. When using a CUE file your MKA files must have no chapters.

Only Kodi 19 (still in beta) plays M4A files. Music Media Helper can convert all MKA files to to M4A.

EDIT: You will need to tag the M4A files for Kodi using MMH or another tagging app like Tagscanner.

BTW: I’ve been using Kodi 19 beta (Windows) for two or three months with no major issues.
 
Last edited:
One more thing. you need to set Kodi Audio settings to HDMI Pass-Through to decode the Atmos stream on your AVR.
 
Foobar can play MKA and M4A files if you add the Foobar FFMPEG component and point it to a newer version of ffmpeg.exe (3.2.1 works, if you have MMH it’s in its program files folder)
 
Kodi 19 beta (nightly builds) for Windows x64 is here:

http://mirrors.kodi.tv/nightlies/windows/win64/master/

Thanks, @HomerJAU. I installed the latest version of Kodi (18 something?), though maybe I'll try the Beta.

But since I'm already comfortable playing M4A files on the Windows Movies & TV app--and since it doesn't require any tagging or CUE files or settings changes--maybe I should just learn MMH first and convert the files to M4A.
 
Foobar can play MKA and M4A files if you add the Foobar FFMPEG component and point it to a newer version of ffmpeg.exe (3.2.1 works, if you have MMH it’s in its program files folder)

Huh. Didn't know about that. Even if they're Atmos?
 
maybe I should just learn MMH first and convert the files

Easy as. There’s a tool to Extract Audio from MKV/MKA. Select output as M4A and select all the MKA files. Click: Convert

Huh. Didn't know about that. Even if they're Atmos?

Yes. On my PC (without an AVR) they play as 8 channel (just the TrueHD core). But with an Atmos AVR via HDMI you should get Atmos.
 
No tagging required. My last post before editing I accidentally pasted old text... (now removed)
 
I have some Dolby Atmos files that were encoded as MKA.

I'm new to Kodi, but Kodi doesn't seem to want to play them. (Maybe there's a plug-in I need?)

If I right-click on one of the files to choose a different app to open it with, Windows File Explorer freezes up.

Does anyone know of an easy way to convert MKA to M4A? I know I can play M4A Atmos files with the Windows "Movies & Music" app built in to Windows 10.

I can tag the songs of the single MKA file with MP3Tag, actually. I import as usual to Kodi Library and the relevant tags are being recognized. The only thing which is not working is gapless playback.
 
Yes. On my PC (without an AVR) they play as 8 channel (just the TrueHD core). But with an Atmos AVR via HDMI you should get Atmos.

So I have the latest version of foobar (1.6.2), which has the ffmpeg component (ver. 4.3.1) installed by default. (I.e., that component is one of the grayed-out ones.) But if I try to play an MKA file, foobar complains that it's an "unsupported track format."
 
I’ll take a look shortly (not on my PC now). Sounds like the component needs a setting changed.
 
Here's my config for ffmpeg Decoder Wrapper component in Foobar: (with my file configs)
fooffmpeg.PNG
 
Here's my config for ffmpeg in Foobar:
View attachment 61247

Well, I don't want to ask you to be my personal foobar guru, Garry--you're not getting paid enough! But in my settings, there are no sub-branches under Playback > Decoding.

The only place I see FFmpeg Decoders is at the very top of the settings menu tree, under "Components," and there, it's greyed out, as it's one of the automatically installed components.
 
I can only suggest you download and re-install the latest Ffmpeg component. :unsure:

https://www.foobar2000.org/components/view/foo_input_ffmpeg
BTW: I think I added the two file types (MKA and M4A) to ffmpeg list.

Now I get it (partly, anyway): I was talking about foobar's built-in ffmpeg decoder; you were talking about the FFmpeg Decoder Wrapper, which needs to be downloaded and installed separately.

Still trying to figure out how to add new file types (and get them to play). I'll get there eventually...
 
Last edited:
Thanks, @HomerJAU. I installed the latest version of Kodi (18 something?), though maybe I'll try the Beta.

But since I'm already comfortable playing M4A files on the Windows Movies & TV app--and since it doesn't require any tagging or CUE files or settings changes--maybe I should just learn MMH first and convert the files to M4A.

Kodi 19 is the version you want, not 18, for M4A. No gapless playback however.
 
I actually came here today to find out how to get VLC to play Atmos correctly, but am intrigued by playing in Foobar, my favorite player. I've been through all the steps above, but no luck so far. I'll keep plugging to see what I missed. LOL I'm doing this at my working/main PC which just has an analog connection to an old 5.1 AVR, not the HTPC. I'll go to the HTPC and configure it. :unsure: DOH!

So anyway the only pc app I have that will play mkv w/Atmos correctly at this time is PowerDVD. The OSD from my AVR will display Atmos/TrueHD when I toggle my remote. VLC will only cause my AVR to show Dolby Surround.
This is l on my main AUDIO rig btw of which my HTPC is HDMI connected to, to be clear (I hope)
I really gotta start sleeping more.....
 
Back
Top