Atmos MKV stutters on VLC media player

QuadraphonicQuad

Help Support QuadraphonicQuad:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

GOS

2K Club - QQ Super Nova
QQ Supporter
Joined
Apr 23, 2013
Messages
21,753
Location
Central Illinois
Lately, VLC media player on my PC stutters almost constantly while playing mkv files with an Atmos soundtrack. I can take that same mkv file and play with Windows Media Player and it's perfect. I've searched the web, and they always give fixes, most of the fixes (settings) are already there.

Anyone else have this issue? It's so bad at times, my Denon avr Atmos "signal" completely drops off and it can go for 30 seconds with zero audio.
What's that you say? Why don't I just use windows media player? Because I prefer VLC, I guess. It has worked better before, but never been this bad.
 
I had some unreliability issues also a couple of months ago. I went back to previous version and everything worked. The version is on the downstairs computer. I will post it when I can.
 
The VLC version that is working fine for me is ver. 3.0.18.

1708633009710.png
 
I'm about to tell VLC to go to hell. What a pain in the ass it is. I would fully move to Windows Media Player, only when you have a single mkv file with the whole album, there is no way to click to next song. (VLC has that function)

Now, if I could figure out how to split MKV into individual tracks...... Yes, I know HOmer's MMH supposedly does it. I tried it, and it worked. Only the individual tracks had no sound. Obviously, did something wrong, can't imagine what.
 
OK, so I figured out what the problem is, but it's not an answer I really want to hear. See below. When I leave the passthrough disabled, then Atmos mkv files play flawlessly. But, if I leave it there, then my Auro-3D titles don't play in true Auro-3D. They go the upmix route as I can tell by pushing my Denon info button and it shows the signal without heights being active.

If I then change passthrough to Enabled, then Auro-3D play perfectly and the signal shows the heights being active. Unfortunately, having it set as enabled then makes Atmos have major dropouts, at times approching 45 seconds.

Based on this finding, any thoughts from all you gurus?

1708645943357.png
 
When I leave the passthrough disabled, then Atmos mkv files play flawlessly.
If pass-through is disabled, doesn't that mean the TrueHD/Atmos audio is being decoding internally by VLC and sent out as 7.1?
 
And, as predicted, and my original problem. I put the setting back to passthrough enabled...and the Atmos doesn't work. Massive dropouts, 30-40 seconds long.
 
To add to my confusion, there is the whole issue of the audio settings that can be changed on the taskbar of my windows PC. You know, when you have your PC connected to your AVR via HDMI......suddenly, when you hover over the speaker icon on PC, it shows my AVR. Denon. If you right click on that speaker icon, you have multiple choices (you have to have something selected)
Stereo, 5.1, 7.1 or Dolby Atmos. If I change some of those settings, it can have odd effects.....so I honestly don't know what it means to change those. I mean, my AVR knows exactly what my system is...so not sure how the PC speaker icon interacts with other settings.
 
I hope others chime in, but if you bitstream through most drivers they change the stream because they go through the sound mixer. The Wasapi driver avoids that and it passes streams bit perfect. It should be available to use. My guess is you would choose it somewhere in VLC
 
Back
Top